Mustang Forum - Mustang World

Mustang Grilles, Mustang Windshield banners, Mustang Bumper inserts and more at MW

Go Back   Mustang Forum - Mustang World > Technical Discussion > 5.0L Performance

Thread Tools
Old 09-07-2013, 01:44 PM   #1
Registered User
Join Date: Feb 2007
Location: san diego
Posts: 324
Couldn't get my car to hook at the track!

I went to the track yesterday and could not get my car to stop spinning the rear wheels. When the car had just a CAI I was digging doing 9.3 in the 1/8 mile. Now my cars has a HCI set up, with G farces in the rear and couldn't luanch if my life depended on it only doing a 10.3 sec peeling out the hole time. Car has a 5 speed T5 And 2.73 LSD rear. 1500 rpm to 2000 launches weren't happening any thing lower and the car would hop.....lag.. Then go. All in all I need some pointers please guys Thanks
SJFox89 is offline   Reply With Quote
Old 09-16-2013, 02:44 PM   #2
331 LX
Join Date: Jul 2001
Location: Double-Wide on solid Foundation
Posts: 31,183
What tire was on the car?

It's basically pointless IMO to go to the track without at least a DR...

Edit- Yea put a Drag Radial on it and take the pressure down to 17 or so and go from there..
Xbox GT- Turbo 306LX <> PSN GT- Turbo306LX
331 LX is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -8. The time now is 08:00 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2012