Mustang Forum - Mustang World

Mustang Grilles, Mustang Windshield banners, Mustang Bumper inserts and more at MW Speedshop.com

Go Back   Mustang Forum - Mustang World > Technical Discussion > 5.0L Performance

Reply
 
Thread Tools
Old 03-12-2015, 03:48 AM   #1
Damouth
Registered User
 
Join Date: Nov 2005
Location: Roanoke, VA
Posts: 181
Idling issue

ok, so it was raining one day, going to work, ran through a puddle and when i push the clutch in the idle went to about 1700 rpms. So, I pull air filter off, clean it(cold air into the fender), put it back, still same problem, is intermittent though. I deal with it it, starts happening worse and more frequent, gets to the point to were its not intermittent anymore and idle is about 2100 rpms now. I have replaced IAC 3 times, with 3 different types, finally ending with a motorcraft IAC. Still, idling about 2100 rpms. So, I replace the MAF, put 36lb inj, MAF is calibrated to them and a spacer between upper and lower intake. Problem is still there, no better and no worse. DOES ANYONE HAVE ANY SUGGESTIONS, its driving me crazy, this is my daily driver. Ihave disconnected the IAC and it idles about 900 rpms, but does not like to idle when vehicle is cold
Damouth is offline   Reply With Quote
Old 03-12-2015, 05:11 AM   #2
03RedFireGT
Registered User
 
Join Date: Jan 2004
Location: Corn Fields of Central Illinois
Posts: 6,038
Disconnected/broken vacuum line. Get a can of carb cleaner, and start spraying down the lines. When the idle changes, that's where you focus efforts on replacing lines.
__________________
03RedFireGT is offline   Reply With Quote
Old 03-12-2015, 01:00 PM   #3
Damouth
Registered User
 
Join Date: Nov 2005
Location: Roanoke, VA
Posts: 181
checked for vacuum leaks, none found. i sprayed Everything down, lol. I did get it better. TPS was at 1.33, adjusted it down to .988 and the idle doesnt go sky hgh anymore, now driving, check engine light comes on and no one around here can get the check the old eec system to get codes. And i work at a damn Ford dealer, lol... WTF!!!!
Damouth is offline   Reply With Quote
Old 04-29-2015, 06:32 AM   #4
Cozzb
Bonified
 
Join Date: Jun 2000
Location: Northern Virginia, USA
Posts: 1,556
Use this page and count the flashes of the check engine light for codes

http://www.thorssell.net/hbook/eectest.html
__________________
65 Mustang Fastback 2+2.
Cozzb is offline   Reply With Quote
Old 04-29-2015, 11:44 AM   #5
modo
That Guy
 
Join Date: Jan 2002
Location: In a house
Posts: 10,248
get the motor at operating temp then disconnect the IAC plug from the IAC. use a screw driver and set the idle to where you want it with the set screw on the throttle body. hookup the IAC again and if your check engine light is on pull the battery for 5 min.
__________________

93 GT
66 Coupe
modo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2012 Mustangworld.com